Gmailの連携方法
Gmailの連携方法(OKKI CRM)
この記事では、OKKI CRMにGmailアカウントを連携させる手順をご紹介します。
連携には、事前にGoogle側での設定が必要です。
【事前準備】Googleアカウントの設定
Step 1. GmailへのログインとIMAP設定
- Googleアカウントページ にアクセスし、Gmailアカウントでログインしてください。

- Gmailを開き、右上の歯車アイコン(⚙️)から 「すべての設定」 をクリック。

- 「メール転送と POP/IMAP」タブを選択。
- 「IMAPアクセス」 の項目で、「IMAPを有効にする」 を選択し、「変更を保存」 をクリック。

Step 2. 二段階認証設定
- Googleアカウント管理ページ にアクセス。

- 左メニューから 「セキュリティ」 をクリック。

- 「二段階認証プロセス」 を有効化(※本人確認が必要です)。
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- 「パスキー」「認証アプリ」「SMS(電話番号)」「バックアップコード」のいずれかで設定。
- 設定完了後、緑のチェックマークが表示されます。
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【本設定】OKKI CRMでの連携手順
- OKKI CRMにログインし、「メール」>「メールアドレスを追加」 をクリック。

- メールプロバイダー選択画面で 「Gmail」 を選択。

- 連携するGoogleアカウントを選択(またはログイン)。

- 詳細をクリックし、okki-gmail-oauth-prod2(安全ではないページ)に移動

- 「次へ」をクリックし、「すべてを選択」をクリックします。

※こちらの画面は初回連携時のみ表示されます。

※2回目以降はこちらの画面が表示されます
次に、サーバー情報を入力します:
- サーバータイプ:
HTTPプロキシを選択 - サーバー(IPアドレス / ポート):以下の3つのうちいずれか1つを入力
116.62.172.59 / 30088116.62.149.253 / 30081116.62.132.232 / 30086
- サーバーのユーザー名:空白のまま(入力不要)

以上で、GmailとOKKI CRMの連携が完了します。
連携後は、OKKI上でGmailの送受信・管理が可能になります。
連携後は、OKKI上でGmailの送受信・管理が可能になります。
Tokenの取得が成功するも連携ができない以下のようなエラーが発生する場合

原因:
お使いのドメインでは IMAP アクセスが無効になっています。
Gmailメールアカウントが属するドメインは、Google Workspace(旧 G Suite)の企業向けメールアカウントであり、そのドメインの管理者が Google Admin コンソールで IMAP アクセス権限をオフにしています。
なぜこのエラーが発生するのか?
CRM やメール集約ツール、自動化システムなど、サードパーティのプラットフォームが Gmail メールアカウントに接続する際には、通常 IMAPプロトコルを利用してメールを読み取る必要があります。
個人用の Gmail アカウント(@gmail.com)の場合、IMAP はデフォルトで有効になっていますが、Google Workspace の企業向けメールアカウント(例:@yourcompany.com)では、セキュリティ上の理由から IMAP がデフォルトで無効になっているか、管理者によって制御されています。これは従業員が公式のクライアント以外の手段で会社のメールボックスにアクセスすることを防ぐためです。
解決策:
該当するメールアカウントが所属するドメインの Google Workspace 管理者(通常は IT 部門またはメールアカウントの作成者)に連絡し、Google Admin コンソールで IMAP を有効にしてもらう必要があります。